Documentation Rhizome

Documentation de l'association Rhizome, contribution bienvenue !

Outils pour utilisateurs

Outils du site


Panneau latéral

technique:materiel:switchs

Switchs

Mikrotik RB250GS

Conso à vide port 100Mbps activé port gigabit activé volume traffic
1.9W +0.2W/port +0.9W/port pas d'influence

RB750UP+

À désactiver

  • Client DHCP
  • Serveur DHCP
  • Firewall
  • Routeur
  • Autre…

Pour faire un switch 5 ports

Le RB750UP possède deux interfaces réseau, l'une sur ether1 (ou POE in) et l'autre switché sur les sur ports 2 à 5. Par défaut, les paquets sont routés entre les deux interfaces. Pour en faire un switch 5 ports, on peut bridgé ether1 et ether2 :

Source : http://chiliproject.tetaneutral.net/projects/tetaneutral/wiki/Mikrotik

[admin@rb750up-chiwawa] > interface bridge add name=bridge1 
[admin@rb750up-chiwawa] > interface bridge port add bridge=bridge1 interface=ether1-gateway 
[admin@rb750up-chiwawa] > interface bridge port add bridge=bridge1 interface=ether2-master-local 

Activer le POE sur un port

telnet 192.168.88.1

/interface ethernet set ether2 poe-out=on
/interface ethernet set ether2 poe-out=off
Le mode auto ne fonctionne pas pour le matos Ubnt

Configuration IP

Les Switchs ont l'IP 10.42.3.x. Les identifiants sont les mêmes que les APs ubnt.

Upgrade

Il y a plusieurs chose à mettre à jour sur le RB750UP

Bootloader

Pour faire la maj du bootloader :

  • Télécharger le fichier “routerboot” sur la page http://routerboard.com/RB750UP
  • Copier la nouvelle version dans la racine du FTP (se connecter via FTP au switch)
  • Se connecter au switch via Telnet
/system routerboard upgrade
/system reboot
Voir la version courante
[rhizome@MikroTik] > /system routerboard print
       routerboard: yes
             model: 750UP
     serial-number: 2F3F01374D04
  current-firmware: 2.41
  upgrade-firmware: 2.41

Ici, la version est 2.41

Firmware

Pour faire la maj du firmware :

  • Télécharger la dernière version de routerOS sur la page http://www.mikrotik.com/download
  • Copier la nouvelle version dans la racine du FTP (se connecter via FTP au switch)
  • Se connecter au switch via Telnet
  • Il suffit de faire un reboot pour lancer la mise à jour
/system reboot
Voir la version courante
[rhizome@MikroTik] > /system package print
Flags: X - disabled 
 #   NAME                                   VERSION                                   SCHEDULED              
 0   dhcp                                   5.20                                                             
 1   system                                 5.20                                                             
 2 X wireless                               5.20                                                             
 3   routerboard                            5.20                                                             
 4   hotspot                                5.20                                                             
 5   ppp                                    5.20                                                             
 6 X ipv6                                   5.20                                                             
 7   security                               5.20                                                             
 8   routeros-mipsbe                        5.20                                                             
 9   routing                                5.20                                                             
10   advanced-tools                         5.20                                                             
11   mpls                                   5.20  

Ici, la version est 5.20

Mise à jour du Firmware POE

Une nouvelle version du firmware POE est inclus dans la nouvelle version de routerOS (rien à télécharger ici).

[rhizome@MikroTik] /interface ethernet> /interface ethernet poe settings upgrade
Do you really want to upgrade PoE firmware? [y/n] 
y
Please reboot to finish PoE firmware upgrade.
[rhizome@MikroTik] /interface ethernet> /system reboot 
Reboot, yes? [y/N]: 
y
system will reboot shortly
Vérifier la version
[rhizome@MikroTik] > /interface ethernet poe settings print 
                   version: 2.0
  ether1-poe-in-long-cable: no
Nouveautés

Monitorer le POE. Avec la nouvelle version du firmware, on a quelques raffinement comme le monitoring de la consommation des différentes interfaces en direct.

interface ethernet poe monitor [find]

On peut aussi utiliser le mode “câble PoE long”.

interface ethernet poe settings set ether1-poe-in-long-cable=yes

Script de conf complet

# Desactivation des services
ip dhcp-server remove default
ip dhcp-client remove ether1-gateway
ip pool remove default-dhcp
ip firewall nat remove 0
ip filter remove 0
ip filter remove 1
ip filter remove 2
ip filter remove 3
 
# Activation IPv6 (Just 4 Fun)
system package enable ipv6 
 
# IP Rhizome
ip address add address=10.42.3.X interface=ether2-master-local netmask=255.255.0.0 comment="IP Rhizome"
 
# Suppression IP par défaut (! mettre l'IP Rhizome avant !)
ip address remove 0
 
# Bridge entre les deux interfaces
interface bridge add name=bridge1 
interface bridge port add bridge=bridge1 interface=ether1-gateway 
interface bridge port add bridge=bridge1 interface=ether2-master-local
 
# Utilisateurs
user add name=rhizome group=full comment=Rhizome password=<mdp AP>
user remove admin

Condensateur

Sans modification, et malgré toutes les mises à jour, le switch fonctionne mal en POE : si le câble entre l’injecteur POE et le switch est long (c'est le cas dans la plupart de nos installations présentes et futures), alors les appareils branchés sur les ports POE sont sans cesse rebootés.

Pour résoudre le problème, il faut ajouter un condensateur dans le circuit (source ici).

technique/materiel/switchs.txt · Dernière modification: 2020/10/28 10:20 (modification externe)